viernes, 11 de diciembre de 2015

Ejemplos de Algoritmos - Ejercicio 7 de 16



Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho número es par o impar.

Pseudocódigo

1. Inicio

2. Declaración de variables: N

3. Leer un número

4. Asignarlo a la variable N

5. Si el residuo de dividir a N entre 2 es igual a cero

6. Si es Si: Entonces: Escribir “ Es par”

7. Sino: Escribir “Es impar”

8. Fin_Si

9. Fin


Diagrama de Flujo: 





Ejercicios propuesto:

a. Complete el algoritmo con la instrucción o instrucciones necesarias.
b. Desarrolle un algoritmo que le permita determinar de una lista de números:
b.1. ¿Cuántos están entre el 50 y 75, ambos inclusive?
b.2. ¿Cuántos mayores de 80?
b.3. ¿Cuántos menores de 30?

El algoritmo debe finalizar cuando n (el total de números de la lista), sea igual a 0.


Espero haber ayudado en algo. Hasta la próxima oportunidad!







2 comentarios:

  1. sugerencia usa visio para hacer el diagrama u otro software open source para los flujogramas

    ResponderEliminar
    Respuestas
    1. Hola gato fla, gracias por la visita y el aporte de tu comentario!!
      Muy buena sugerencia!
      Los mejores deseos! Hasta cualquier momento!

      Eliminar