martes, 14 de julio de 2015

Ejemplos de algoritmos con informes y rupturas de control



1.-Tenemos el fichero secuencial DATOS.DAT cuyos campos son: DNI, NOMBRE, APELLIDOS, DIRECCION y PROVINCIA. Listar por impresora todos los registros cuya provincia sea una determinada que introduciremos por teclado.

PROGRAMA provincia
ENTORNO:
fi <- 55
c <- 0
pag <- 1
pro <- Espacios( 15 )
ALGORITMO:
Borrar_pantalla( )
EN 10,20 ESCRIBIR "Provincia: "
EN 10,32 LEER pro
ABRIR "DATOS.DAT"
Activar_impresora( )
MIENTRAS NO Eof( ) HACER
SI provincia = pro ENTONCES
SI fi = 55 ENTONCES
HACER Cabecera
FINSI
EN fi,5 ESCRIBIR dni
EN fi,15 ESCRIBIR nombre
EN fi,35 ESCRIBIR apellidos
EN fi,65 ESCRIBIR direccion
fi <- fi + 1
c <- c + 1
FINSI
Siguiente_registro( )
FINMIENTRAS
SI pag <> 1 ENTONCES
EN fi + 2,20 ESCRIBIR "Total de personas: "
EN fi + 2,39 ESCRIBIR c
FINSI
Activar_pantalla( )
CERRAR "DATOS.DAT"
FINPROGRAMA

SUBPROGRAMA Cabecera
Salto_pagina( )
EN 2,65 ESCRIBIR "P g.: "
EN 2,71 ESCRIBIR pag
EN 4,10 ESCRIBIR "Relaci¢n de las personas que viven en la provincia: "
EN 4,62 ESCRIBIR pro
EN 6,7 ESCRIBIR "D.N.I."
EN 6,18 ESCRIBIR "Nombre"
EN 6,40 ESCRIBIR "Apellidos"
EN 6,68 ESCRIBIR "Direcci¢n"
EN 7,4 ESCRIBIR "------------------------------------------------------------------------"
fi <- 9
pag <- pag + 1
FINSUBPROGRAMA


2.-En el fichero secuencial VENTAS.DAT, est n almacenadas las ventas de los productos durante el d¡a, cuyos campos son: NART y VENTAS. Se desea hacer un programa que liste por impresora todas las ventas realizadas durante el día.

PROGRAMA ventas
ENTORNO:
total <- 0
uno <- 0
fi <- 55
sw <- 0
aux <- 0
pag <- 1
ALGORITMO:
Borrar_pantalla( )
Activar_impresora( )
ABRIR "VENTAS.DAT"
MIENTRAS NO Eof( ) HACER
SI fi = 55 ENTONCES
HACER Cabecera
FINSI
SI sw = 0 ENTONCES
aux <- nart
sw <- 1
FINSI
SI nart = aux ENTONCES
uno <- uno + ventas
SINO
HACER Imprimir
uno <- 0
aux <- nart
uno <- ventas
FINSI
Siguiente_registro( )
FINMIENTRAS
HACER Imprimir
EN fi + 2,20 ESCRIBIR "Unidades vendidas: "
EN fi + 2,39 ESCRIBIR total
Activar_pantalla( )
CERRAR "VENTAS.DAT"
FINPROGRAMA

SUBPROGRAMA Imprimir
EN fi,32 ESCRIBIR aux
EN fi,42 ESCRIBIR total
fi <- fi + 1
total <- total + uno
FINSUBPROGRAMA

SUBPROGRAMA Cabecera
Salto_pagina( )
EN 2,65 ESCRIBIR "P g.: "
EN 2,71 ESCRIBIR pag
EN 4,20 ESCRIBIR "LISTADO DE LAS VENTAS DE LOS PRODUCTOS AL DIA: "
EN 4,68 ESCRIBIR Fecha_sistema( )
EN 6,30 ESCRIBIR "N£mero"
EN 6,40 ESCRIBIR "Cantidad"
EN 7,18 ESCRIBIR "-----------------------------------------------------"
fi <- 9
pag <- pag + 1
FINSUBPROGRAMA


48.-Dado el fichero secuencial ARTICULOS.DAT, cuyos campos son: NART, ARTICULO, PVP, STOCK y MINIMO. En otro fichero VENTAS.DAT, estén almacenadas las modificaciones de los productos durante el día, cuyos campos son: NART2, VENTAS y TIPO. El campo TIPO puede tomar los valores 0 (venta) y 1 (compra). Se desea hacer un programa que realice una actualizaci¢n del fichero de ARTICULOS y un listado por impresora de las entradas y salidas de los artículos.

PROGRAMA modifica
ENTORNO:
entra <- 0
sale <- 0
total <- 0
fi <- 55
sw <- 0
aux <- 0
pag <- 1
ALGORITMO:
Borrar_pantalla( )
Activar_impresora( )
ABRIR "ARTICULOS.DAT"
Primer_registro( )
ABRIR "SALIDAS.DAT"
Primer_registro( )
ABRIR "VENTAS.DAT"
Primer_registro( )
SELECCIONAR "VENTAS.DAT"
MIENTRAS NO Eof( ) HACER
SI fi = 55 ENTONCES
HACER Cabecompras
FINSI
SI sw = 0 ENTONCES
aux <- nart2
HACER Buscar
sw <- 1
FINSI
SI nart2 = aux ENTONCES
HACER Calculos
SINO
HACER Grabar
HACER Compra
entra <- 0
sale <- 0
aux <- nart2
HACER Buscar
HACER Calculos
FINSI
Siguiente_registro( )
FINMIENTRAS
HACER Grabar
HACER Compra
SELECCIONAR "SALIDAS.DAT"
fi <- 55
MIENTRAS NO Eof( ) HACER
SI fi = 55 ENTONCES
HACER Cabesal
FINSI
MIENTRAS nart3 <> nart HACER
SELECCIONAR "ARTICULOS.DAT"
Siguiente_registro( )
FINMIENTRAS
aux <- nart3
HACER Buscar
HACER Sale
SELECCIONAR "SALIDAS.DAT"
Siguiente_registro( )
FINMIENTRAS
EN fi + 4,55 ESCRIBIR "Total: "
EN fi + 4,62 ESCRIBIR total
Activar_pantalla( )
Cerrar_ficheros( )
BORRAR "SALIDAS.DAT"
FINPROGRAMA

SUBPROGRAMA Calculos
SI tipo = 0 ENTONCES
entra <- entra + ventas
SINO
sale <- sale + ventas
FINSI
FINSUBPROGRAMA

SUBPROGRAMA Grabar
stock <- stock + entra - sale
SELECCIONAR "ARTICULOS.DAT"
Escribir_registro( )
nart3 <- aux
ventas3 <- sale
SELECCIONAR "SALIDAS.DAT"
Final_fichero( )
Escribir_registro( )
FINSUBPROGRAMA

SUBPROGRAMA Cabecompras
Salto_pagina( )
EN 2,65 ESCRIBIR "P g.: "
EN 2,71 ESCRIBIR pag
EN 4,20 ESCRIBIR "LISTADO DE LAS ENTRADAS DE ARTICULOS AL DIA: "
EN 4,66 ESCRIBIR Fecha_sistema( )
EN 6,18 ESCRIBIR "N£mero"
EN 6,35 ESCRIBIR "Art¡culo"
EN 6,65 ESCRIBIR "Cantidad"
EN 7,15 ESCRIBIR "----------------------------------------------------------------"
fi <- 9
pag <- pag + 1
FINSUBPROGRAMA

SUBPROGRAMA Compra
EN fi,16 ESCRIBIR aux
EN fi,30 ESCRIBIR articulo
EN fi,67 ESCRIBIR entra
fi <- fi + 1
FINSUBPROGRAMA

SUBPROGRAMA Cabesal
Salto_pagina( )
EN 2,65 ESCRIBIR "P g.: "
EN 2,71 ESCRIBIR pag
EN 4,20 ESCRIBIR "LISTADO DE SALIDAS DE ARTICULOS AL DIA: "
EN 4,60 ESCRIBIR Fecha_sistema( )
EN 6,8 ESCRIBIR "N£mero"
EN 6,16 ESCRIBIR "Art¡culo"
EN 6,40 ESCRIBIR "Cantidad"
EN 6,54 ESCRIBIR "PVP"
EN 6,64 ESCRIBIR "Importe"
EN 7,6 ESCRIBIR "------------------------------------------------------------------------------"
fi <- 9
pag <- pag + 1
FINSUBPROGRAMA

SUBPROGRAMA Sale
Salto_pagina( )
SI stock < minimo ENTONCES
EN fi,4 ESCRIBIR "*"
FINSI
EN fi,6 ESCRIBIR nart3
EN fi,14 ESCRIBIR articulo
EN fi,40 ESCRIBIR ventas
EN fi,54 ESCRIBIR pvp
EN fi,65 ESCRIBIR ventas * pvp
total <- total + ventas * pvp
fi <- fi + 1
FINSUBPROGRAMA

SUBPROGRAMA Buscar
MIENTRAS nart <> aux HACER
SELECCIONAR "ARTICULOS.DAT"
Siguiente_registro( )
FINMIENTRAS
FINSUBPROGRAMA


Espero haber ayudado en algo. Hasta la próxima oportunidad!








No hay comentarios:

Publicar un comentario

       

Etiquetas

Academy (23) Accediendo a datos con ADO .NET (30) Acceso a la red (30) Algoritmo (34) Algoritmos en JAVA (2) Ampliación de clases (2) APRENDA A PROGRAMAR COMO SI ESTUVIERA EN PRIMERO - Autores : IKER AGUINAGA (3) APRENDA A PROGRAMAR COMO SI ESTUVIERA EN PRIMERO - Autores : IKER AGUINAGA (10) Aprendiendo a desarrollar en Windows 8 (5) Aprendiendo UML en 24 Horas (Autor : Joseph Schmuller ) (30) Arquitectura (29) Arquitectura del Computador (3) Arquitectura del Computador - Historia de la informática (1) Asignación de direcciones IP (1) Aspectos fundamentales de bases de datos (5) Auditoría de la dirección (2) Auditoría de Sistemas (3) Auditoría Informática - Un enfoque práctico - Mario G . Piattini y Emilio del Peso (7) Avanzado (23) Base de Datos (66) Básico (23) Bios (29) Business Productivity Online Suite - BPOS (3) Capa de Red (22) Capa de Transporte (16) Capítulo 1 - Documentos HTML5 (6) Capítulo 10. API Web Storage (2) Capítulo 11. API IndexedDB (4) Capítulo 12. API File (1) Capítulo 2. Estilos CSS y modelos de caja (7) Capítulo 3. Propiedades CSS3 (4) Capítulo 4. Javascript (6) Capítulo 5. Video y audio (6) Capítulo 6. Formularios y API Forms (8) Capítulo 7. API Canvas (5) Capítulo 8. API Drag and Drop (2) Capítulo 9. API Geolocation (2) CCNA1 v5.0 (178) CCNA1 v6.0 (23) CCNA2 v5.0 (26) CCNA3 v5.0 (25) CCNA4 v5.0 (23) CD-ROM (3) Chapter 1 How does Xamarin.Forms fit in? (7) Chapter 2 Anatomy of an app (5) Cisco (279) Cloud Computing (3) CNNA v5.0 Routing & Switching (199) CNNA v6.0 Routing & Switching (2) Codigo (2) Computadora (32) Configuración (29) Configuración de un sistema operativo de red (21) Control (29) Creación de tipos de datos y tablas (3) Creación y Administración de bases de datos (3) Creando la Interface de la Aplicación Windows (50) Creating Mobile Apps with Xamarin.Forms (13) Cuenta (29) Curso (32) Curso Aprendiendo a Programar (25) Datos (3) Desarrollando en Windows 8 - AVANZADO (2) Desarrollando en Windows 8 - BÁSICO (3) Desarrollando en Windows 8 - INTERMEDIO (2) Desarrollo (2) Desarrollo .Net (21) Desarrollo avanzado de Windows Store Apps usando C# (1) Desarrollo basado en conceptos de Ingeniería de Software para Visual Studio (2) DESARROLLO DE APLICACIONES WINDOWS CON MICROSOFT .NET (37) DESARROLLO DE APLICACIONES WINDOWS CON MICROSOFT .NET (Autor: Luis Dueñas Huaroto) (29) Desarrollo en Microsoft Visual Studio (44) Desarrollo en Microsoft Visual Studio - AVANZADO (15) Desarrollo en Microsoft Visual Studio - BÁSICO (14) Desarrollo en Microsoft Visual Studio - INTERMEDIO (18) Desarrollo en Windows Phone 8 (13) Diagnostico (4) Diagrama (3) Diagramas de actividades (2) Diagramas de colaboraciones (2) Diagramas de secuencias (2) Digital (2) Diplomado (2) Disco (29) Disco Duro (4) Diseño de aplicaciones de Windows 8 en HTML 5 (7) Dispositivos Electrónicos (11) Doctorado (2) Ejemplos (3) Ejemplos de algoritmos (27) El camino hacia el CSS3 (3) El diseño web flexible (6) El elemento de diseño Canvas (3) El enfoque de los sistemas (3) El flujo de un programa (2) El gran libro de HTML5 - CSS3 y Javascript - Autor: Juan Diego Gauchat (55) El principio de organicidad (7) Electrónica (2) Elementos de un sistema (5) Empresas (2) Entrada y salida (4) Entropía y neguentropía (7) Estrategia (2) Estructura de un programa Java (12) Estructuras de almacenamiento (10) Estructuras de control (6) Estructuras de las tablas en SQL Server (2) Estructuras fundamentales de los datos (2) Ethernet (21) Evolución y Familias de los Microprocesadores (15) Exámen (23) Exploración de la red (23) Extensión de clases (4) Facebook (4) Familia Intel (15) Forefront (8) Función (3) Funciones de una red (12) Funciones de una red informática (1) Fundamentos de C# para absolutos principiantes (17) Fundamentos de programación en Java (50) Generaciones de la computadora (5) Gestión (3) Gestión de riesgos - Auditoría de Sistemas (1) GONZALO MARTÍNEZ (1) Grupos Facebook (1) Harvard (29) Historia de las computadoras (11) HTML5 y CSS3 - Autor: Christophe Aubry (99) HTML5 y CSS3 aplicadal texto (7) HTML5 y CSS3 para los formularios (15) Imágenes (2) Implementación de Windows 7 (11) Información (31) Informática (29) Ingeniería (4) Instalar (29) Inteligencia (2) Inteligencia de Negocios con SQL Server (3) Intermedio (23) Internet (29) Internet Explorer 9 (3) Introducción a ASP.NET 5 (8) Introducción a Java (7) Introducción a jQuery (8) Introducción a la Auditoría de Sistemas (2) Introducción a la teoría general de sistemas (Oscar Johansen Bertoglio) (39) Introducción a Networking (2) Introducción a Window Forms (5) Introducción al acceso a datos con ADO .NET (9) Investigación de Operaciones (12) Java (52) Jump Start de consultas en las bases de datos de Microsoft SQL Server 2012 (8) La definición de un Sistema (6) La evolución del HTML y del CSS (3) La nueva sintaxis HTML5 (12) LA QUINTA DISCIPLINA en la práctica (Autor : Peter Senge) (28) Las animaciones en CSS3 (5) Las transformaciones CSS3 (11) Las transiciones con CSS3 (8) Licenciamiento Microsoft (3) Local Area Network (LAN) - Red de Area Local (2) Lógico (2) Los elementos de la estructura en html5 (9) Los elementos multimedia: audio y vídeo (2) Los estilos de caja en CSS3 (13) Los nuevos selectores de CSS3 (6) Maestría (2) Mantenimiento de Mouse y Teclado (2) Manual de Microsoft SQL Server - Full Transact SQL (67) Manual de soporte técnico para escuelas sobre windows 7 (42) Marco Teorico de Investigación de Operaciones (6) Medios de Almacenamiento (11) Medios de Networking (2) Mejorando la Interface de las Aplicaciones Windows (26) Memoria Tipos y Clases (5) Método (2) Metodología (1) Microsoft (324) Microsoft Lync 2010 (7) Microsoft Silverlight 4.0 (2) Microsoft Virtual Academy (356) Modelo (2) Modelo OSI y TCP-IP (2) Modelos con poco grado de dificultad de Programación Lineal - Investigación de Operaciones (13) Modelos con razonable grado de dificultad de Programación Lineal - Investigación de Operaciones (10) Modelos de desafio de Programación Lineal - Investigación de Operaciones (5) Modelos difíciles de Programación Lineal - Investigación de Operaciones (5) Modelos Fáciles de Programación Lineal - Investigación de Operaciones (13) Modelos lineales con solver (3) Modulo (23) Movimiento (2) Mozilla (29) MS SQL Server (76) MS Virtualization para Profesionales VMware - Gestión (3) MS Virtualization para Profesionales VMware- Plataforma (4) MVA (263) Negocio (2) Nivel Avanzado Desarrollo .Net (6) Nivel Básico Desarrollo .Net (11) Nivel Intermedio Desarrollo .Net (8) Normas técnicas peruanas y su evolución - Auditoría de Sistemas (1) Nube Privada - Avanzado (6) Nube Privada - Básico (6) Nube Privada - Intermedio (6) Office 365 (3) Optimización de Escritorio (10) Optimización de Escritorio - Avanzado (4) Optimización de Escritorio - Básico (3) Optimización de Escritorio - Intermedio (3) ORACLE 10g - ADMINISTRACIÓN Y ANÁLISIS (3) Oracle 10g y el Grid Computing (3) Organización aleatoria y secuencial (1) Partes principales de la Mainboard (12) Perceptron (2) Perfil (2) Periféricos de Entrada / Salida (15) Pesi (2) PHP y MySQL - Manual de aprendizaje para crear un sitio web - Autor : Olivier ROLLET (79) Plan (2) Plataforma (29) PMBOK (24) PMBOK - Guía de los fundamentos para la dirección de proyectos (24) PMBOK - INFLUENCIA DE LA ORGANIZACIÓN Y CICLO DE VIDA DEL PROYECTO (6) PMBOK - Introducción (11) PMBOK - PROCESOS DE LA DIRECCIÓN DE PROYECTOS (5) Prevención - Herramientas e Instrumentos de Medida (9) Principios básicos de enrutamiento y switching (152) Proceso (2) Proceso de auditoría de sistemas informáticos (2) Programación en Android - Auor : Salvador Gómez Oliver (46) Programación paso a paso de C# - Autor : Nacho Cabanes (16) Protocolos y comunicaciones de red (17) Proyecto (2) Qué es un sistema (4) Red de Área Local Inalámbrica (WLAN) (4) Redes (30) Redes inalámbricas - WIRELESS - Conocimiento general (15) Redes neuronales (2) Redes y Comunicaciones (45) Reparación de Fuentes - UPS - Estabilizadores (10) Reparación de Impresoras (9) Reparación de Monitores (16) Router (29) Seguridad en la Nube (3) Seminario (23) Server (24) Sharepoint 2010 - Nivel Básico (6) Sharepoint 2010 - Niveles Avanzados (18) Sharepoint 2010 - Niveles Avanzados - Básico (8) Sharepoint 2010 - Niveles Avanzados - Intermedio (9) Sinergia y recursividad (4) Sistema (33) Sistema de Cableado Estructurado (9) Software (30) SOLUCIÓN GRÁFICA DE MODELOS DE PROGRAMACIÓN LINEALES - INVOPE (8) Soporte a Infraestructura (3) SQL (38) SQL Azure - Introducción (3) Subsistemas de control (4) Tablas (4) Tarjeta Principal del Sistema (10) Tarjetas de Interfaces (7) Tecnología (31) Tecnologías LAN (1) TEORÍA GENERAL DE SISTEMAS (1) Tic (2) Tipo (2) TML5 y CSS3 - Autor: Christophe Aubry (12) Trabajando con el Formulario (7) Un diseño HTML5/CSS3: dConstruct 2011 (3) Un diseño HTML5/CSS3: FlipThru (2) Un diseño HTML5/CSS3: The Cat Template (2) Usando Controles Windows Forms (12) Usando Herramientas de Datos de Visual Studio (6) Ventas (2) Virtualización Hyper - V Nivel Básico (5) Virtualización Hyper - V Nivel Intermedio (5) What’s New in Windows 8.1 Security (4) Window (29) Windows 7 Segunda Fase - AVANZADO (4) Windows 7 Segunda Fase - BÁSICO (6) Windows 7 Segunda Fase - INTERMEDIO (4) Windows 8 - Vista Previa (4) Windows 8.1 To Go (2) Windows Azure (3) Windows Phone 7 (2) Windows Server 2008 R2 (3) Windows Server 2012 - Gestión y Automatización (3) Windows Server 2012 R2 Essentials (7) Windows Server 2012: Almacenamiento (5) Windows Server 2012: Identidad y Acceso (4) Windows Server 2012: Revisión Técnica (7) Xamarin (1)

Páginas vistas en total según Google