viernes, 10 de julio de 2015

Ejemplos de algoritmos con arrays bidimensionales



1.-Generar una matriz de 4 filas y 5 columnas con numeros aleatorios entre 1 y 100, e imprimirla.

PROGRAMA matriz
ENTORNO:
DIMENSIONAR A[ 4, 5 ]
i <- 1
fi <- 10
co <- 15
ALGORITMO:
Borrar_pantalla( )
EN 6,25 ESCRIBIR "Elementos de la matriz"
MIENTRAS i <= 4 HACER
j <- 1
MIENTRAS j <= 5 HACER
A[ i, j ] <- Int( Rnd( ) * 100 ) + 1
EN fi,co ESCRIBIR A[ i, j ]
co <- co + 5
j <- j + 1
FINMIENTRAS
co <- 15
fi <- fi + 2
i <- i + 1
FINMIENTRAS
FINPROGRAMA


2.-Generar una matriz de 4 filas y 5 columnas con n£meros aleatorios entre 1 y 100, y hacer su matriz transpuesta.

PROGRAMA transpuesta
ENTORNO:
DIMENSIONAR A[ 4, 5 ]
DIMENSIONAR B[ 5, 4 ]
fi <- 8
co <- 10
fit <- 8
cot <- 40
i <- 1
ALGORITMO:
Borrar_pantalla( )
EN 6,15 ESCRIBIR "Matriz uno"
EN 6,45 ESCRIBIR "Transpuesta"
MIENTRAS i <= 4 HACER
j <- 1
MIENTRAS j <= 5 HACER
A[ i, j ] <- Int( Rnd( ) * 100 ) + 1
B[ j, i ] <- A[ i, j ]
EN fi,co ESCRIBIR A[ i, j ]
EN fit,cot ESCRIBIR B[ j, i ]
co <- co + 4
fit <- fit + 2
j <- j + 1
FINMIENTRAS
fi <- fi + 2
co <- 10
fit <- 8
cot <- cot + 4
i <- i + 1
FINMIENTRAS
FINPROGRAMA


3.-Cargar en una matriz las notas de los alumnos de un colegio en funcion del numero de cursos (filas) y del n£mero de alumnos por curso (columnas).

PROGRAMA notas
ENTORNO:
i <- 1
j <- 1
ALGORITMO:
Borrar_pantalla( )
EN 10,20 ESCRIBIR "N£mero de cursos: "
EN 10,39 LEER M
EN 12,20 ESCRIBIR "N£mero de alumnos: "
EN 12,40 LEER N
DIMENSIONAR A[ M, N ]
Borrar_pantalla( )
EN 2,25 ESCRIBIR "Introducci¢n de las notas"
MIENTRAS i <= M HACER
EN 10,25 ESCRIBIR "Curso: "
EN 10,32 ESCRIBIR i
MIENTRAS j <= N HACER
EN 14,25 ESCRIBIR "Alumno: "
EN 14,33 ESCRIBIR j
EN 16,25 ESCRIBIR "Nota: "
EN 16,32 LEER A[ i, j ]
j <- j + 1
FINMIENTRAS
i <- i + 1
FINMIENTRAS
FINPROGRAMA


4.-Ordenar una matriz de M filas y N columnas por la primera columna utilizando el m‚todo SHELL (por insercion).

PROGRAMA ordenar
ENTORNO:
i <- 1
j <- 1
fi <- 10
co <- 15
M <- 0
N <- 0
ALGORITMO:
Borrar_pantalla( )
EN 10,20 ESCRIBIR "Filas: "
EN 10,27 LEER M
EN 12,20 ESCRIBIR "Columnas: "
EN 12,30 LEER N
DIMENSIONAR A[ M, N ]
Borrar_pantalla( )
MIENTRAS i <= M HACER
MIENTRAS j <= N HACER
A[ i, j ] = Int( Rnd( ) * 100 ) + 1
EN fi,co ESCRIBIR A[ i, j ]
co <- co + 5
j <- j + 1
FINMIENTRAS
co <- 15
fi <- fi + 2
i <- i + 1
FINMIENTRAS
salto <- Int( M / 2 )
MIENTRAS salto >= 1 HACER
sw <- 1
MIENTRAS sw <> 0 HACER
sw <- 0
i <- 1
MIENTRAS i <= M - salto HACER
SI A[ i, 1 ] > A[ i + salto, 1 ] ENTONCES
HACER Cambios
FINSI
i <- i + 1
FINMIENTRAS
FINMIENTRAS
salto <- Int( salto / 2 )
FINMIENTRAS
FINPROGRAMA

SUBPROGRAMA Cambios
j <- 1
MIENTRAS j <= N HACER
aux <- A[ i + salto, j ]
A[ i + salto, j ] <- A[ i, j ]
A[ i, j ] <- aux
j <- j + 1
FINMIENTRAS
sw <- 1
FINSUBPROGRAMA



Espero haber ayudado en algo. Hasta la próxima oportunidad!








No hay comentarios:

Publicar un comentario en la entrada