lunes, 21 de diciembre de 2015

Ejemplos de Algoritmos - Ejercicio 13 de 16



Desarrolle un algoritmo que funcione como caja registradora.


Pseudocódigo

1. Inicio

2. Declaración de Variables:

Sub_total=0,Total = 0

3. Ingrese “Código de Producto y Precio:”

4. Almacenar Codigo_Producto, Precio

5. Imprimir líneas de títulos del recibo de pago

6. Mientras Código_Producto <> “ “

7. Subtotal = Subtotal + Precio

8. Imprimir Codigo_Producto, Precio

9. Ingrese “Código de Producto y Precio:”

10. Fin_Mientras

11. IVA = Subtotal * 0,15

12. Total = Subtotal + IVA

13. Imprimir “Sub Total : “, Subtotal

14. Imprimir “ IVA : “, IVA

15. Imprimir “Total: “, Total

16. Fin


Diagrama de Flujo: 





Ejercicios propuestos:

Realice el mismo algoritmo utilizando la herramienta IF-THEN – ELSE.



Espero haber ayudado en algo. Hasta la próxima oportunidad!







No hay comentarios:

Publicar un comentario en la entrada