domingo, 20 de diciembre de 2015

Ejemplos de Algoritmos - Ejercicio 12 de 16



Desarrolle un algoritmo para la empresa Constructora Tecnovivir Casas C.A., que le permita calcular e imprimir la nómina para su cancelación a un total de 50 obreros calificados a quienes debe cancelar por horas trabajadas. La hora trabajada se pautó en 30.000 Bolívares.


Pseudocódigo

1. Inicio

2. Declaración de Variables:

Numero_Obreros =50
Numero_Hora_Trabajadas = 0
Total_nomina = 0

3. Imprimir líneas de títulos de la nómina

4. Leer Datos

5. Mientras Numero_Obreros>0

6. Salario = Numero_Hora_Trabajada * 30

7. Total_nómina= Totalnómina + Salario

8. Numero_Obreros = Numero_Obreros - 1

9. Imprimir Registro

10. Leer Datos

11. Fin_Mientras

12. Imprimir “Total : “, Total_nómina

13. Fin


Diagrama de Flujo: 




Ejercicios propuestos:

a. ¿Qué pasaría si no se decrementa al número de obreros en uno?
b. Realice el mismo algoritmo utilizando la herramienta FOR,
c. Realice el mismo algoritmo utilizando la herramienta REPEAT.



Espero haber ayudado en algo. Hasta la próxima oportunidad!







No hay comentarios:

Publicar un comentario en la entrada