viernes, 10 de julio de 2015

Ejemplos de algoritmos con presentacion en pantalla y cabeceras



1.-Introducir una frase por teclado. Imprimirla cinco veces en filas consecutivas, pero cada impresion ir desplazada cuatro columnas hacia la derecha.

PROGRAMA frase
ENTORNO:
frase <- Espacios( 30 )
ALGORITMO:
Borrar_pantalla( )
EN 5,15 ESCRIBIR "Frase: "
EN 5,22 LEER frase
fi <- 8
co <- 15
veces <- 0
MIENTRAS veces <= 5 HACER
EN fi,co ESCRIBIR frase
veces <- veces + 1
co <- co + 4
fi <- fi + 1
FINMIENTRAS
FINPROGRAMA


2.-Hacer un pseudocodigo que imprima los n£meros del 0 al 100, controlando las filas y las columnas.

PROGRAMA numeros
ENTORNO:
c <- 0
ALGORITMO:
Borrar_pantalla( )
EN 5,20 ESCRIBIR "Los n£meros del 0 al 100 son: "
fi <- 7
col <- 5
MIENTRAS c < 101 HACER
EN fi,col ESCRIBIR c
c <- c + 1
col <- col + 4
SI col > 75 ENTONCES
fi <- fi + 2
col <- 5
FINSI
FINMIENTRAS
FINPROGRAMA


3.-Comprobar si un numero mayor o igual que la unidad es primo.

PROGRAMA primo
ENTORNO:
res <- "S"
ALGORITMO:
MIENTRAS res = "S" HACER
Borrar_pantalla( )
numero <- 0
sw <- 0
MIENTRAS numero < 1 HACER
EN 8,10 ESCRIBIR "N£mero: "
EN 8,18 LEER numero
FINMIENTRAS
i <- numero - 1
MIENTRAS i > 1 Y sw <> 1 HACER
SI numero = Int( numero / i ) * i ENTONCES
sw = 1
SINO
i <- i - 1
FINSI
FINMIENTRAS
SI sw = 1 ENTONCES
EN 10,10 ESCRIBIR "no es primo"
SINO
EN 10,10 ESCRIBIR "s¡ es primo"
FINSI
HACER Mas
FINMIENTRAS
FINPROGRAMA

SUBPROGRAMA Mas
res <- " "
MIENTRAS res <> "S" Y res <> "N" HACER
ESCRIBIR "Desea introducir m s n£meros (S/N): "
LEER res
res <- Convertir_mayusculas( res )
FINMIENTRAS
FINSUBPROGRAMA


4.-Introducir un numero menor de 5000 y pasarlo a numero romano.

PROGRAMA romano
ENTORNO:
res <- "S"
ALGORITMO:
MIENTRAS res = "S" HACER
Borrar_pantalla( )
num <- 0
MIENTRAS num < 1 O num > 5000 HACER
EN 8,10 ESCRIBIR "N£mero: "
EN 8,18 ESCRIBIR num
FINMIENTRAS
col <- 15
MIENTRAS num >= 1000 HACER
EN 15,col ESCRIBIR "M"
num <- num - 1000
col <- col + 1
FINMIENTRAS
SI num >= 900 ENTONCES
EN 15,col ESCRIBIR "CM"
num <- num - 900
col <- col + 2
FINSI
SI num >= 500 ENTONCES
EN 15,col ESCRIBIR "D"
num <- num - 500
col <- col + 1
FINSI
MIENTRAS num >= 100 HACER
EN 15,col ESCRIBIR "C"
num <- num - 100
col <- col + 1
FINMIENTRAS
SI num >= 90 ENTONCES
EN 15,col ESCRIBIR "XC"
num <- num - 90
col <- col + 2
FINSI
SI num >= 50 ENTONCES
EN 15,col ESCRIBIR "L"
num <- num - 50
col <- col + 1
FINSI
SI num >= 40 ENTONCES
EN 15,col ESCRIBIR "XL"
num <- num - 40
col <- col + 2
FINSI
MIENTRAS num >= 10 HACER
EN 15,col ESCRIBIR "X"
num <- num - 10
col <- col + 1
FINMIENTRAS
SI num = 9 ENTONCES
EN 15,col ESCRIBIR "IX"
num <- num - 9
col <- col + 2
FINSI
SI num >= 5 ENTONCES
EN 15,col ESCRIBIR "V"
num <- num - 5
col <- col + 1
FINSI
SI num >= 4 ENTONCES
EN 15,col ESCRIBIR "IV"
num <- num - 4
col <- col + 2
FINSI
MIENTRAS num > 0 HACER
EN 15,col ESCRIBIR "I"
num <- num - 1
col <- col + 1
FINMIENTRAS
HACER Mas
FINMIENTRAS
FINPROGRAMA

SUBPROGRAMA Mas
res <- " "
MIENTRAS res <> "S" Y res <> "N" HACER
ESCRIBIR "Desea introducir m s n£meros (S/N): "
LEER res
res <- Convertir_mayusculas( res )
FINMIENTRAS
FINSUBPROGRAMA


5.-Introducir una frase por teclado. Imprimirla en el centro de la pantalla.

PROGRAMA centro
ENTORNO:
res <- "S"
frase <- Espacios( 40 )
ALGORITMO:
MIENTRAS res = "S" HACER
Borrar_pantalla( )
EN 5,15 ESCRIBIR "Frase: "
EN 5,22 LEER frase
EN 12,40 - Int( Longitud( frase ) / 2 ) ESCRIBIR frase
HACER Mas
FINMIENTRAS
FINPROGRAMA


6.-Realizar la tabla de multiplicar de un numero entre 0 y 10.

PROGRAMA tabla
ENTORNO:
num <- -1
ALGORITMO:
HACER Numero
Borrar_pantalla( )
EN 5,10 ESCRIBIR "Tabla de multiplicar del n£mero: "
EN 5,40 LEER num
i <- 0
fi <- 8
MIENTRAS i <= 10 HACER
EN fi,15 ESCRIBIR num
EN fi,19 ESCRIBIR " * "
EN fi,23 ESCRIBIR i
EN fi,25 ESCRIBIR " = "
EN fi,29 ESCRIBIR num * i
fi <- fi + 1
i <- i + 1
FINMIENTRAS
FINPROGRAMA

SUBPROGRAMA Numero
MIENTRAS num < 0 HACER
Borrar_pantalla( )
EN 10,25 ESCRIBIR "N£mero: "
EN 10,33 LEER num
FINMIENTRAS
FINSUBPROGRAMA



Espero haber ayudado en algo. Hasta la próxima oportunidad!







No hay comentarios:

Publicar un comentario en la entrada