viernes, 10 de julio de 2015

Ejemplos de algoritmos con arrays unidimensionales



1.-Crear un array unidimensional de 20 elementos con nombres de personas. Visualizar los elementos de la lista debiendo ir cada uno en una fila distinta.

PROGRAMA nombres
ENTORNO:
DIMENSIONA datos[ 20 ]
i <- 1
ALGORITMO:
Borrar_pantalla( )
fi <- 10
MIENTRAS i < 21 HACER
EN fi,10 ESCRIBIR "Nombre: "
EN fi, 18 LEER datos[ i ]
i <- i + 1
FINMIENTRAS
Borrar_pantalla( )
i <- 1
fi <- 3
EN 1,20 ESCRIBIR "Elementos de la lista"
MIENTRAS i < 21 HACER
EN fi,28 ESCRIBIR datos[ i ]
fi <- fi + 1
i <- i + 1
FINMIENTRAS
FINPROGRAMA


2.-Hacer un programa que lea las calificaciones de un alumno en 10 asignaturas, las almacene en un vector y calcule e imprima su media.

PROGRAMA notamedia
ENTORNO:
DIMENSIONA notas[ 10 ]
suma <- 0
media <- 0
ALGORITMO:
Borrar_pantalla( )
fi <- 7
PARA i DESDE 1 HASTA 10 HACER
EN fi,15 ESCRIBIR "Nota "
EN fi,20 ESCRIBIR i
EN fi,21 ESCRIBIR ": "
EN fi,23 LEER notas[ i ]
fi <- fi + 1
FINPARA
PARA i DESDE 1 HASTA 10 HACER
suma <- suma + notas[ i ]
FINPARA
media <- suma / 10
EN 20,20 ESCRIBIR "Nota media: "
EN 20,32 ESCRIBIR media
FINPROGRAMA


3.-Usando el segundo ejemplo, hacer un programa que busque una nota en el vector.

PROGRAMA buscar
ENTORNO:
i <- 0
num <- 0
ALGORITMO:
Borrar_pantalla( )
ESCRIBIR "Nota a buscar: "
LEER num
ITERAR
i <- i + 1
SI notas[ i ] = num O i = 10 ENTONCES
SALIR
FINSI
FINITERAR
SI notas[ i ] = num ENTONCES
ESCRIBIR "Encontrado en posici&oacute;n: "
ESCRIBIR i
SINO
ESCRIBIR "No existe esa nota"
FINSI
FINPROGRAMA



Espero haber ayudado en algo. Hasta la próxima oportunidad!







2 comentarios:

  1. Muy bueno el algoritmo sobre vectores

    ResponderEliminar
    Respuestas
    1. Hola Anónimo, gracias por la visita y el aporte de tu comentario.
      Los mejores deseos! Hasta cualquier momento!

      Eliminar