viernes, 10 de julio de 2015

Ejemplos de algoritmos con arrays multidimensionales



1.-Crear una tabla de 3 paginas, 4 filas y 5 columnas donde el primer elemento valga 1, el segundo 2, el tercero 3 y as¡ sucesivamente, e imprimirla.

PROGRAMA tabla
ENTORNO:
DIMENSIONAR A[ 3, 4, 5 ]
i <- 1
j <- 1
k <- 1
b <- 0
fi <- 8
co <- 12
ALGORITMO:
MIENTRAS i <= 3 HACER
Borrar_pantalla( )
EN fi,co ESCRIBIR "Elementos de la p gina: "
EN fi,co + 24 ESCRIBIR i
fi <- fi + 2
MIENTRAS j <= 4 HACER
MIENTRAS k <= 5 HACER
b <- b + 1
A[ i, j, k ] <- b
EN fi,co ESCRIBIR A[ i, j, k ]
co <- co + 4
k <- k + 1
FINMIENTRAS
fi <- fi + 2
co <- 12
j <- j + 1
FINMIENTRAS
EN fi + 2,20 ESCRIBIR "Pulse INTRO para continuar ..."
Pausa( )
i <- i + 1
FINMIENTRAS
FINPROGRAMA


2.-Se dispone de una tabla de 5 p ginas, 10 filas y 20 columnas, que se refieren al centro, al curso y al numero de alumnos de un colegio respectivamente. Imprimir la nota media por curso y la nota media maxima y su centro de pertenencia.

PROGRAMA notas
ENTORNO:
max <- -1
sum <- 0
centro <- 0
i <- 1
j <- 1
k <- 1
fi <- 10
ALGORITMO:
Borrar_pantalla( )
EN 8,18 ESCRIBIR "Centro"
EN 8,38 ESCRIBIR "Nota media"
MIENTRAS i <= 5 HACER
MIENTRAS j <= 10 HACER
MIENTRAS k <= 20 HACER
sum <- sum + A[ i, j, k ]
k <- k + 1
FINMIENTRAS
j <- j + 1
FINMIENTRAS
EN fi,20 ESCRIBIR i
EN fi,40 ESCRIBIR sum / 20
fi <- fi + 2
SI sum / 20 > max ENTONCES
max <- sum / 20
centro <- i
FINSI
i <- i + 1
FINMIENTRAS
EN fi + 2,20 ESCRIBIR "Nota media m xima: "
EN fi + 2,39 ESCRIBIR max
EN fi + 4, 20 ESCRIBIR "pertenece al centro: "
EN fi + 4,41 ESCRIBIR centro
FINPROGRAMA


3.-Una empresa guarda en una tabla de 3x12x4 las ventas realizadas por sus tres representantes a lo largo de doce meses de sus cuatro productos, VENTAS[ representante, mes, producto ]. Queremos proyectar el array tridimensional sobre uno de dos dimensiones que represente el total de ventas, TOTAL[ mes, producto ], para lo cual sumamos las ventas de cada producto de cada mes de todos los representantes. Imprimir ambos arrays.

PROGRAMA ventas
ENTORNO:
** Las variables est n definidas en cada subprograma
ALGORITMO:
HACER Volcar
HACER Imp_Tres
HACER Imp_Dos
FINPROGRAMA

SUBPROGRAMA Volcar
DIMENSIONAR TOTAL[ 12, 4 ]
j <- 1
MIENTRAS j <= 12 HACER
k <- 1
MIENTRAS k <= 4 HACER
i <- 1
suma <- 0
MIENTRAS i <= 3 HACER
suma <- suma + VENTAS[ i, j, k ]
i <- i + 1
FINMIENTRAS
TOTAL[ j, k ] <- suma
k <- k + 1
FINMIENTRAS
j <- j + 1
FINMIENTRAS
FINSUBPROGRAMA

SUBPROGRAMA Imp_Tres
i <- 1
MIENTRAS i <= 3 HACER
Borrar_pantalla( )
fi <- 8
co <- 12
EN fi,co ESCRIBIR "Ventas del representante: "
EN fi,co + 26 ESCRIBIR i
fi <- fi + 2
j <- 1
MIENTRAS j <= 12 HACER
k <- 1
MIENTRAS k <= 4 HACER
EN fi,co ESCRIBIR VENTAS[ i, j, k ]
co <- co + 4
k <- k + 1
FINMIENTRAS
fi <- fi + 2
co <- 12
j <- j + 1
FINMIENTRAS
Pausa( )
i <- i + 1
FINMIENTRAS
FINSUBPROGRAMA

SUBPROGRAMA Imp_Dos
Borrar_pantalla( )
j <- 1
EN 8,20 ESCRIBIR "Ventas totales"
fi <- 10
co <- 16
MIENTRAS j <= 12 HACER
k <- 1
MIENTRAS k <= 4 HACER
EN fi,co ESCRIBIR TOTAL[ j, k ]
co <- co + 4
k <- k + 1
FINMIENTRAS
fi <- fi + 2
co <- 12
j <- j + 1
FINMIENTRAS
FINSUBPROGRAMA



Espero haber ayudado en algo. Hasta la próxima oportunidad!







No hay comentarios:

Publicar un comentario en la entrada