viernes, 10 de julio de 2015

Ejemplos de algoritmos con bucles y tomas de decisión



1.-Hacer un pseudocodigo que imprima los numeros del 1 al 100.

PROGRAMA contador1
ENTORNO:
c <- 0
ALGORITMO:
Borrar_pantalla( )
MIENTRAS c < 101 HACER
ESCRIBIR c
c <- c + 1
FINMIENTRAS
FINPROGRAMA


2.-Hacer un pseudocodigo que imprima los numeros del 100 al 0, en orden decreciente.

PROGRAMA contador2
ENTORNO:
c <- 100
ALGORITMO:
Borrar_pantalla( )
MIENTRAS c <= 0 HACER
ESCRIBIR c
c <- c - 1
FINMIENTRAS
FINPROGRAMA


3.-Hacer un pseudocodigo que imprima los numeros pares entre 0 y 100.

PROGRAMA pares
ENTORNO:
c <- 2
ALGORITMO:
Borrar_pantalla( )
MIENTRAS c < 101 HACER
ESCRIBIR c
c <- c + 2
FINMIENTRAS
FINPROGRAMA


4.-Hacer un programa que imprima la suma de los 100 primeros numeros.

PROGRAMA suma
ENTORNO:
c <- 1
suma <- 0
ALGORITMO:
Borrar_pantalla( )
MIENTRAS c <= 100 HACER
suma <- suma + c
c <- c + 1
FINMIENTRAS
ESCRIBIR "La suma de los 100 primeros n£meros es: "
ESCRIBIR suma
FINPROGRAMA


5.-Hacer un pseudocódigo que imprima los numeros impares hasta el 100 y que imprima cuantos impares hay.

PROGRAMA impares
ENTORNO:
c <- 1
son <- 0
ALGORITMO:
Borrar_pantalla( )
MIENTRAS c < 100
ESCRIBIR c
c <- c + 2
son <- son + 1
FINMIENTRAS
ESCRIBIR "El n£mero de impares: "
ESCRIBIR son
FINPROGRAMA


6.-Hacer un pseudocodigo que imprima todos los numeros naturales que hay desde la unidad hasta un numero que introducimos por teclado.

PROGRAMA natural
ENTORNO:
i <- 0
n <- 0
ALGORITMO:
Borrar_pantalla( )
ESCRIBIR "Introduce un n£mero: "
LEER n
MIENTRAS i < n HACER
i <- i + 1
ESCRIBIR i
FINMIENTRAS
FINPROGRAMA


7.-Introducir tantas frases como queramos y contarlas.

PROGRAMA frases
ENTORNO:
res <- "S"
frase <- Espacios( 30 )
c <- 0
ALGORITMO:
Borrar_pantalla( )
MIENTRAS res = "S" HACER
ESCRIBIR "Frase: "
LEER frase
c <- c + 1
ESCRIBIR "Deseas introducir m s frases (S/N): "
LEER res
FINMIENTRAS
ESCRIBIR "El n£mero de frases introducidas son: "
ESCRIBIR c
FINPROGRAMA


8.-Hacer un pseudocodigo que solo nos permita introducir S o N.

PROGRAMA sn
ENTORNO:
res <- " "
ALGORITMO:
Borrar_pantalla( )
MIENTRAS res <> "S" Y res <> "N" HACER
ESCRIBIR "Introduce S o N"
LEER res
res <- Convertir_may£sculas( res )
FINMIENTRAS
FINPROGRAMA


9.-Introducir un numero por teclado. Que nos diga si es positivo o negativo.

PROGRAMA signo
ENTORNO:
num <- 0
ALGORITMO:
Borrar_pantalla( )
ESCRIBIR "Introduce un n£mero: "
LEER num
SI num >= 0 ENTONCES
ESCRIBIR "es positivo"
SINO
ESCRIBIR "es negativo"
FINSI
FINPROGRAMA


10.-Introducir un numero por teclado. Que nos diga si es par o impar.

PROGRAMA paridad
ENTORNO:
num <- 0
ALGORITMO:
Borrar_pantalla( )
ESCRIBIR "Introduce un n£mero: "
LEER num
SI num = int( num / 2 ) * 2 ENTONCES
ESCRIBIR "es par"
SINO
ESCRIBIR "es impar"
FINSI
FINPROGRAMA


11.-Imprimir y contar los multiplos de 3 desde la unidad hasta un numero que introducimos por teclado.

PROGRAMA multiplo3
ENTORNO:
i <- 3
n <- 0
c <- 0
ALGORITMO:
Borrar_pantalla( )
ESCRIBIR "N£mero: "
LEER n
MIENTRAS i <= n HACER
SI i = int( i / 3 ) * 3 ENTONCES
ESCRIBIR i
c <- c + 1
FINSI
i <- i + 1
FINMIENTRAS
ESCRIBIR "El n£mero de m£ltiplos de 3 son: "
ESCRIBIR c
FINPROGRAMA


12.-Hacer un pseudocodigo que imprima los numeros del 1 al 100. Que calcule la suma de todos los numeros pares por un lado, y por otro, la de todos los impares.

PROGRAMA par_impar
ENTORNO:
i <- 1
sumapar <- 0
sumaimp <- 0
ALGORITMO:
Borrar_pantalla( )
MIENTRAS i < 101 HACER
SI i = int( i / 2 ) * 2 ENTONCES
sumapar <- sumapar + i
SINO
sumaimp <- sumaimp + i
FINSI
i <- i + 1
FINMIENTRAS
ESCRIBIR "La suma de los pares es: "
ESCRIBIR sumapar
ESCRIBIR "La suma de los impares es: "
ESCRIBIR sumaimp
FINPROGRAMA


13.-Imprimir y contar los numeros que son multiplos de 2 o de 3 que hay entre 1 y 100.

PROGRAMA multiplo_2_3
ENTORNO:
i <- 1
c <- 0
ALGORITMO:
Borrar_pantalla( )
MIENTRAS i < 101 HACER
SI i = int( i / 2 ) * 2 O i = int( i / 3 ) * 3 ENTONCES
c <- c + 1
ESCRIBIR i
FINSI
i <- i + 1
FINMIENTRAS
ESCRIBIR "El n£mero de m£ltiplos es de: "
ESCRIBIR c
FINPROGRAMA


14.-Hacer un pseudocodigo que imprima el mayor y el menor de una serie de cinco numeros que vamos introduciendo por teclado.

PROGRAMA mayor_menor
ENTORNO:
con <- 0
n <- 0
maximo <- 0
minimo <- 99999
ALGORITMO:
Borrar_pantalla( )
MIENTRAS con <= 5 HACER
ESCRIBIR "N£mero: "
LEER n
SI n > maximo ENTONCES
maximo = n
FINSI
SI n < minimo ENTONCES
minimo <- n
FINSI
con <- con + 1
FINMIENTRAS
ESCRIBIR "El mayor de los n£meros es: "
ESCRIBIR maximo
ESCRIBIR "El menor de los n£meros es: "
ESCRIBIR minimo
FINPROGRAMA


15.-Introducir dos numeros por teclado. Imprimir los numeros naturales que hay entre ambos numeros empezando por el m s pequeño, contar cuantos hay y cuantos de ellos son pares. Calcular la suma de los impares.

PROGRAMA par_impar
ENTORNO:
num1 <- 0
num2 <- 0
aux <- 0
son <- 0
pares <- 0
sumaimpa <- 0
ALGORITMO:
Borrar_pantalla( )
ESCRIBIR "N£mero: "
LEER num1
ESCRIBIR "N£mero: "
LEER num2
SI num1 > num2 ENTONCES
aux <- num1
num1 <- num2
num2 <- aux
FINSI
MIENTRAS num1 >= num2 HACER
ESCRIBIR num1
son <- son + 1
SI num1 = int( num1 / 2 ) * 2 ENTONCES
pares <- pares + 1
SINO
sumaimpa <- sumaimpa + num1
FINSI
num1 <- num1 + 1
FINMIENTRAS
ESCRIBIR "N£meros visualizados: "
ESCRIBIR son
ESCRIBIR "Pares hay: "
ESCRIBIR pares
ESCRIBIR "La suma de los impares es: "
ESCRIBIR sumaimpa
FINPROGRAMA



Espero haber ayudado en algo. Hasta la próxima oportunidad!








No hay comentarios:

Publicar un comentario en la entrada